Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

The Table Spreadsheet macro allows you to add an Excel-like spreadsheet. You can work with it both in the page view and page edit mode.


Table of Contents


Adding the Table Spreadsheet macro

1. Insert the macro on a page:

  • Start entering /Table Spreadsheet and select the macro

  • On the editor pane, click Insert -> View more, find the macro and insert it on the page
Info

The page stores your spreadsheet as an attachment. You can find more information about the attachment or download the file in the page settings.



Handy Carousel




Main functions of the Table Spreadsheet macro

  • Cell format
  • Text settings (font, size, type, color)
  • Cell color
  • Border style and color
  • Alignment and text placement
  • Merging cells
  • Freezing rows
  • Automatic functions
  • Multiple sheets
  • Export to CSV
  • Import of Excel (xlsx, csv, ods formats)

Info

The following info regarding the import formats should be noted:

  • xlsx format partially supports formatting;
  • charts, pivot tables and conditional formatting are not supported to import from excel Excel currently.



Filtering the spreadsheet

  1. Click the funnel icon on the editor pane
  2. To sort the spreadsheet, choose the sorting type
  3. To filter the spreadsheet, select a column and click Create filter
  4. Choose a condition to filter the column by
  5. Confirm the settings or clear the filter, if no longer needed


Handy Carousel



Adding a pivot table

  1. Select the pivot table macro on the editor pane
  2. On a new sheet, choose the settings


Handy Carousel



Adding a chart

  1. Select the chart macro on the editor pane
  2. Choose chart settings
Info

The following chart types are available:

  • Line chart
  • Area chart
  • Column chart
  • Bar chart
  • Pie chart



Handy Carousel



Conditional formatting

  1. Select a table
  2. Choose Conditional formatting on the editor pane
  3. Select a suitable formatting preset or set your own rule



Reusing of the Table Spreadsheet macro

  1. Save data in the Table Spreadsheet macro via File->Save (to have a generated name) or via File->Save As (to name it yourself).
  2. Get to the page you wish for the spreadsheet's new location. Open the page in the edit mode and insert the Table Spreadsheet macro. Open the spreadsheet created earlier via File->Open->type your spreadsheet's name.
Info

Once any changes on the page are added and saved, it will affect all the spreadsheets, treated as the same spreadsheet. The attachment, however, will be placed only on the source page where the spreadsheet was originally created and saved.


Tip

To make an independent copy of the spreadsheet to work with it further on, i.e. add it as an attachment of the selected page and reform it without affecting the original one, save the spreadsheet on the page with another name via File->Save As->type your name->Save














Handy Carousel